Opened 17 years ago
Closed 16 years ago
#53 closed task (fixed)
Port graph_utils.h
Reported by: | Alpar Juttner | Owned by: | Balazs Dezso |
---|---|---|---|
Priority: | critical | Milestone: | LEMON 1.0 release |
Component: | core | Version: | hg main |
Keywords: | Cc: | ||
Revision id: |
Description
These files are affected:
- lemon/graph_utils.h
- test/graph_utils_test.h
- test/graph_utils_test.cc
Attachments (3)
Change History (10)
comment:1 Changed 17 years ago by
Owner: | changed from Alpar Juttner to Balazs Dezso |
---|
Changed 17 years ago by
Attachment: | graph_utils_renamings.patch added |
---|
Changed 17 years ago by
Attachment: | graph_typedefs_redesign.patch added |
---|
comment:2 Changed 17 years ago by
comment:3 Changed 17 years ago by
The graph_utils.h could be split to several files:
- The lemon/bits/graph_utils.h would contain the counting operations and graph copy, it would be included automatically from each graph type.
- The special graph related maps could be moved to the graph_maps.h
- The edge_lookup.h could contain the findEdge functions, the ConEdgeIt? and the ArcLookup? classes.
Maybe the maps.h also could be reorganized to more files (basic_maps.h and map_adaptors.h)
comment:4 Changed 17 years ago by
Version: | → hg main |
---|
Changed 17 years ago by
Attachment: | graph_typedef_fix.patch added |
---|
comment:5 follow-up: 6 Changed 17 years ago by
The previous solution did not solve the dependent type problem, so different macro is provided for dependent names. The patch reverts the implementation to the original solution, and it provides TEMPLATE_GRAPH_TYPEDEFS for dependent names.
comment:6 Changed 17 years ago by
Replying to deba:
The previous solution did not solve the dependent type problem, so different macro is provided for dependent names. The patch reverts the implementation to the original solution, and it provides TEMPLATE_GRAPH_TYPEDEFS for dependent names.
It is in the main branch, see [4e2581021300].
comment:7 Changed 16 years ago by
Resolution: | → fixed |
---|---|
Status: | new → closed |
I have uploaded two patches. The first renames types, functions and variables according to naming conventions, and removes some unrelated parts of graph_utils.h. In the second patch there is a new implementation of GRAPH_TYPEDEFS, which can be used easily and it provides map typedefs also.